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OS10 software virtualization
Dell EMC Networking OS10 combines the best of Linux, open computing, and networking to advance open networking disaggregation. 
OS10 is a transformational software platform which provides networking hardware abstraction through a common set of APIs.

You can enable consistency across compute and network resources for your system operator (sysops) groups that require server-like 
manageability, as well as leverage your existing network configuration.

You can simulate OS10 devices using OS10 VM appliances. The OS10 VM appliances execute the same software deployed on OS10-
enabled hardware devices, with the exception of the hardware abstraction layer. The OS10 VM hardware abstraction layer simulates 
hardware devices in a VM environment.

All CLI commands as well as RESTCONF and SNMP interfaces are available in the OS10 simulation environment. You can build sandbox 
environments to learn open networking concepts, and prototype network operations and scripts risk-free.

GNS3

GNS3 is an environment that allows simulation of networking equipment in realistic scenarios. It can be used to emulate, configure, test, 
and troubleshoot networks in a simulated environment. GNS3 allows you to run a small network topology consisting of only a few devices 
on your Windows 10 laptop, or larger network topologies on VMware ESXi hypervisor or VMware Workstation server.

You can use the GNS3 simulator to create a virtual environment to emulate various networks. See GNS3 online documentation and Getting 
started with GNS3 for complete information.

GNS3 can be used to run OS10 simulator VMs. Its most significant and useful features for OS10 include:

• GNS3 client (GUI) — supports creation and visualization of complex network connections

• GNS3 server — component that controls OS10 VM execution (natively supports VMware Workstation or ESXi hypervisors)

• GNS3 client and server separation — client and server can be executed on different machines or operating systems
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OS10 simulation features

All OS10 CLI commands and north-bound interfaces (RESTCONF, SNMP) are available including:

• System management (SSH, AAA, DHCP, and so on)

• Management port

L3 data plane and control plane (using Linux functionality)

Partial support for L2 data plane and control plane (using Linux functionality):

• LACP

• VLAN

• LLDP

• VLT

OS10 feature limitations

• No ACL or QoS support (NPU is not available) — ACL and QoS CLI commands are available (but have no effect on traffic)

• Limited L2 functionality (NPU is not available on simulator) — no spanning-tree control plane functionality

• No breakout mode for simulated ports

• Defaults to S6000-ON hardware platform simulation

Requirements

• Workstation or laptop with 16 GB RAM or larger recommended

• 64-bit x86 CPU with 2 GHz or faster core speed (dual-core or larger recommended)

• SDD with 64 GB available space

• Virtualization environment — you can use either Windows, Linux, or VMware ESXi as a host system for the GNS3 Server VM 
environment

• VMware ESXi server recommended for large network simulation
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• OS10 GNS3 appliance

How to start

1 Download the GNS3 Server VM, then import the VMware ESXi GNS3 Server VM to act as the GNS3 server.

2 Import the GNS3 server OVA, then enable nested virtualization.

3 Boot the GNS3 Server VM.

4 Install the GNS3 client software on your Windows 10 laptop to act as the GNS3 client, then connect to a remote server.

5 Import the OS10 GNS3 appliance.

6 Create nodes (OS10 VM devices) and links for your network.

7 Start the OS10 VM devices.
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Setup GNS3 server
You must first install the GNS3 Server VM to act as the simulated network server. The GNS3 client visualizes the configuration while the 
GNS3 server controls and executes OS10 VMs.

How to start

1 Verify you have met all network requirements.

2 Download the GNS3 Server VM, then import either VMware ESXi GNS3 Server VM or VMware Workstation to act as the GNS3 
server.

3 Import the GNS3 Server OVA, then enable nested virtualization.

4 Boot the GNS3 Server VM.

Prerequisites

• ESXi GNS3 Server VM — download the latest version from Github (always download the latest stable version)

ESXi GNS3 server image is called GNS3.VM.VMware.ESXI<major release number>.<minor release 
number>.<version>.zip (for example, GNS3.VM.VMware.ESXI.2.1.8.zip)

• ESXi Server, version 6.0 or above (version 6.5 or above preferred)

• ESXi Client — either Windows or Linux, or compatible browser

NOTE: GNS3 client and server versions must match. These steps outline how to use VMware ESXi. You can also use the VMware 
Workstation GNS3 VM following similar steps.

1 Go to GNS3 and download the GNS3 VM software.

2 Import the GNS3 VM. Unzip the GNS3 VM file, then import the ESXi GNS3 Server VM (see video on importing an OVA file). Ensure 
that Nested Virtualization is enabled after importing the GNS3 Server OVA.
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3 Boot the VM and configure networking. You need at least one network adapter with connectivity. Configure the IP address of eth0.

You need to use the IP address when configuring the GNS3 client on your laptop. The IP address is shown at boot time, and by 
selecting the Information - Display VM information option.

8 Setup GNS3 server



4 Use the password that you have configured in the gns3_server.conf file to connect the client to the server. This is on the GNS3 
server (GNS3 Server VM appliance). The gns3_server.conf file can be found in /home/.config/GNS3 (your installation may 
differ).

gns3_server.conf example

[Server]

port = 3080
...
user = admin
auth = True
password = admin
...

5 Restart the GNS3 server for any changes to take effect.
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It may take a few seconds to connect to the GNS3 server.
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Setup GNS3 client
Now that you've setup the GNS3 Server VM to act as your server, you are ready to setup the client side of your network to simulate OS10 
devices.

Once you install the GNS3 client on your Windows laptop, you can then connect to the remote GNS3 server. The GNS3 client and server 
must have the same version.

Install GNS3 client on Windows

NOTE: Bare metal GNS3 server functionality on Windows is not supported for OS10 simulation.

1 Go to GNS3 and download the Windows software. The most current software downloads, for example. GNS3-2.1.8-all-in-
one.exe). GNS3 is open source free software but you'll need to create an account to download the software.

If you don't have an account, simply register to create an account. If you do have an account, click Login and enter your username and 
password, then click Login and continue. If you prefer to download GNS3 without creating an account, you can download the 
software from GNS3 GitHub.

2 Click Run to start the installer, then click Next.

3
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3 Click I Agree, then Next to add the shortcut.

4 Select GNS3 and TightVNC Viewer, then click Next. You can also experiment with Wireshark and WinPCAP for packet capturing on 
inter-VM links.

5 Select an installation folder, then click Install.

6 Click Next to complete installation, then click Finish.
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The thank you for installing GNS3 browser displays. Feel free to browse documentation, GNS3 Academy network training content, or 
explore the Marketplace.

Start and configure the GNS3 client

Prerequisite: IP address of a started GNS3 server (an GNS3 server executed as a VM).

1 Click Start > GNS3 in the Windows Start Menu.

You need to configure the GNS3 client to use a remote server rather than a local server; the GNS3 server executed as a guest OS in 
either ESXi or VMware Workstation.

2 Select Remote Server when the GNS3 client starts for the first time. If the client has already started, select Edit > Preferences > 
Server.
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3 Disable the local server, configure the GNS3 server IP address (for example, 10.10.10.100, TCP port is 3080), then enable 
authentication.

4 Use the password that you have configured in the gns3_server.conf file to connect the client to the server. This is on the GNS3 
server (GNS3 server VM appliance).

gns3_server.conf example

[Server]

port = 3080
...
user = admin
auth = True
password = admin
...

5 Restart the GNS3 server for any changes to take effect.

It may take a few seconds to connect to the GNS3 server.

6 Create a project. Select File > New blank project or File > Open project.
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7 Import the GNS3 OS10 appliance (see Import OS10 appliance).

8 Create nodes (OS10 devices) and links (see Using the GNS3 client and GNS3 online documentation).
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Start GNS3 client
The process of using the GNS3 client is straight-forward. Here are the steps:

NOTE: When an OS10 VM starts for the first-time, the boot time is longer. ONIE installs the OS10 image.

1 Start the GNS3 client.

2 Import the OS10 ONIE appliance.

3 Create a VM.

Start GNS3 client

You have two choices:

• Ubuntu: Type gns3 on the command line
• Windows: Start > GNS3

Import the OS10 ONIE appliance

See Import and run OS10 appliance for complete information.

Create a VM

1 Click on the  icon to display all simulated devices (appliance templates).

2 Drag a device to the main topology view to create a new VM.

GNS3 menus

Double-click on the VM name, then enter the new name in the pop-up.
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VM instance menus

Right-click on a VM in the main topology view to open the pull-down menu.

• Start a VM — click Start

• Select the Console menu item to open a device console (if the VM is started)

• Open the Configure menu item to configure a device

Start GNS3 client 17



• Create links between VMs with the  icon — the symbol changes to  when the link creation is active. Click on a VM, select 
the port to connect to, drag the link to another VM, then repeat the operation. Unconnected ports are marked with a red rectangle (for 
example, eth 1/1/3). mgmt 1/1/1 corresponds to the Management interface.

Interface label view

Select View > Show/Hide interface labels to view interface labels.

You can drag interface labels and node labels to their desired position on the topology view.

Topology summary view
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Select View > Docks > Topology summary. The Topology summary shows active/inactive nodes and their console connections.
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Import OS10 appliance
You are now ready to import an OS10 appliance into your simulated network.

1 Unpack the zip file.

• Dell-EMC-OS10-10.4.1.0.gns3a — Dell EMC OS10 GNS3 appliance

• OS10-Installer-10.4.1.0.qcow2 — Virtual disk that stores the OS10 installer binary

• OS10-Disk-1.1.0.vmdk — Virtual disk where ONIE installs OS10

The general format for the file name is OS10_Virtualization_<release_number>V.zip.

Run a zip extraction tool (such as WinZip) if you are using Windows, or run this command if you are using Linux:

unzip OS10_Virtualization_10.4.1.0V.zip
2 Select File > Import Appliance.

3 Select Dell-EMC-OS10-10.4.1.0.gns3a, then click Next.
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4 Select Install the appliance on the main server, then click Next.

5 Import OS10-Disk-1.1.0.vmdk and OS10-Installer-10.4.1.0.qcow2 (if not automatically found by GNS3), then click 
Next.

6 Verify the QEMU binary to be used for running the appliance, click Next, then click Finish to create an appliance called Dell EMC 
OS10 10.4.1E.

Import OS10 appliance 21



7 Create a VM and drag the appliance to the project frame.

8 Connect the VM to a NAT device for network connectivity (see GNS3 online documentation for more information).

9 Start the VM. On first reboot, the VM starts an ONIE image and automatically installs the OS10 image using a standard OS10 installer 
(same as on actual hardware).
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The installation process may take a couple of minutes, depending on the speed of your laptop or server. OS10 will prompt when 
installation completes. The VM starts OS10 directly at subsequent reboots.

See the Dell EMC Networking OS10 Enterprise Edition User Guide for complete information on using OS10. The OS10 VM CLI is 
exactly the same as for OS10 executed hardware devices.
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FAQs
How many OS10 VMs can I run in a GNS3 environment?

It depends but the rule of thumb is [GNS3 server VM memory size in qcow2 - 2GB] / 2 GB per OS10 VM.

How do I convert from a virtual disk image format to another?

On Linux, you can use qemu-img convert. For example:

qemu-img convert -O vmdk Ubuntu.qcow2 Ubuntu.vmdk

This command converts VHD disk image to a VMDK image. Refer to the qemu-ing man page and online documentation for more 

information.

ATTENTION REVIEWERS:

[placeholder to finish]
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